2007/02/14

Contribuire ad Openoffice


Ho aperto una presentazione fatta con Powerpoint in Openoffice Impress, una semplice presentazione di immagini con una musica di sottofondo che accompagna le transizioni da una diapositiva all'altra. Con mia sorpresa ho scoperto che non si udiva alcuna musica.
Al che ho pensato: "Sarà un' incompatibilità con Powerpoint" aggiungo il sottofondo io ed è fatta....bene...non si può fare.
Ho cercato in lungo e in largo e a parte una soluzione arzigogolata che andrò ad illustrarvi dopo non si può fare.
Essendo Software libero però possiamo influire sulle scelte degli sviluppatori
basta votare il bug/feature qui: http://www.openoffice.org/issues/show_bug.cgi?id=24969
(se non siete iscritti potete iscrivervi qui: http://www.openoffice.org/servlets/Join)

Ora la (poco) pratica soluzione che ho trovato sul forum di openoffice

creare una macro...


Tools > Macros > Organize Macros > OpenOffice.org Basic...
Sotto Macro clicca il nome del tuo documento per aprire l'albero
Clicca Standard
Clicca New
Rinomina il nuovo modulo o accetta il default e clicca OK
Nella finestra Basic che appare, inserite il testo qui sotto, sostituendo con i percorsi sul vostro computer

REM ***** BASIC *****

'Impress - Play background music using an external player
'When activated from a mouse event during a slideshow,
'The external player does not show on the screen, however
'if activated from the design view, the external player pops up

Sub playBackgroundMusic

' For Linux
Shell ("/usr/bin/xmms",1,"/disks/zip.1/zip.1/mp3/alexandre_desplat/syriana/16-mirage.mp3")

' For Windows
' Shell ("C:\Program Files\QuickTime\QuickTimePlayer.exe",1,"E:\mp3\alexandre_desplat\syriana\16-mirage.mp3")

End Sub


Chiudere la finestra Basic
In Impress selezionate il titolo della prima slide
Slide show > Interaction...
ad Action at mouse click, scegliete Run Macro
Cliccate Browse...
Selezionate la Libreria e la vostraMacro .
Cliccate OK
Cliccate OK
Fate pertire la presentazione (F5)
Cliccate il titolo modificato
E via con la musica di sottofondo....

Etichette: , , , , ,

13 Commenti:

Anonymous Michele Abbondanza ha detto...

Finalmente grazie a te sono riuscito a trovare qualcosa di semplice. Devo dire che ancora non riesco. Ma questo trucco funziona anche con altre versioni OO oppure solo con l'ultima? Io sto lavorando con quella portabile, e mi è venuto il dubbio.
(mabbond[et]email.it)

9:00 PM  
Blogger Andrea ha detto...

Questo commento è stato eliminato dall'autore.

9:55 PM  
Blogger Andrea ha detto...

Ora non è più necessario, la versione 2.3 di openoffice da poco uscita ha corretto questo antipatico bug. Se sei costretto a rimanere ad una versione più vecchia, io avevo usato questa soluzione con la versione 2.1.
Ti consiglio comunque di aggiornare :-)

10:00 PM  
Anonymous Michele ha detto...

Grazie Andrea, in effetti stavo usando la versione portable che probabilmente non è aggiornata. Ora sto scaricando la 2.3.0, ma quindi ci dovrebbe essere la possibilità di inserire un brano musicale direttamente senza altri sotterfugi. Grazie di tutto.

5:52 PM  
Blogger Andrea ha detto...

Ho seguito le vicende del bug e lo danno per chiuso, purtroppo non ho ancora potuto provare personalmente perchè privo di banda larga e quindi aspetterò ancora un po' ad aggiornarlo.Rimane solo un piccolo problema da risolvere che è stato schedulato per la versione 2.4 ovvero il file sonoro non può essere messo in loop, ma pazienza, non è così terribile(almeno per me) :-)

7:18 PM  
Anonymous Michele ha detto...

Ciao Andrea, ho appena caricato la versione 2.3.0, ma ancora non riesco a fare quello che volevo. Forse mi sono spiegato male. Io volevo inserire un brano musicale che cominciasse alla prima o seconda dia e che andasse avanti fino alla fine della presentazione. Invece seleziono il file lo inserisco nella prima dia e poi quiando clicco per andare sulla seconda dia il suono termina. Ho dato un'occhio anche all'help in linea, ma mi pare uguale alla versione vecchia. Tu dici che è stato risolto oppure stavamo parlando di due cose diverse?
Grazie.

5:52 PM  
Blogger Andrea ha detto...

Il problema è proprio quello di cui parli tu che da qui http://www.openoffice.org/issues/show_bug.cgi?id=24969
sembrerebbe proprio risolto. domani dovrei avere a disposizione un Openoffice 2.3 e farò una prova. Se riesco farò un post sul mio blog per spiegare come si fa.

Ciao

9:40 AM  
Blogger Andrea ha detto...

Funziona!!!!

Doc. Frankenstein

1:29 PM  
Anonymous Michele ha detto...

Ma come hai fatto? Io non riesco!

12:26 PM  
Blogger Andrea ha detto...

Se leggi il mio ultimo post lo spiego
:-)
http://tinyurl.com/2v9299

12:55 PM  
Anonymous Michele ha detto...

Non ci capisco una mazza di inglese, scusa.

4:48 PM  
Blogger Andrea ha detto...

Bhè a dire i lvero è in italiano comunque mandami una mail a

meandrea chiocciola tiscali punto it

e ti spiego


Ciao!!

7:08 PM  
Anonymous michele ha detto...

Ciao, scusa ... sono riuscito a farlo. Peccato che trasformandolo i pdf si perda il suono. Vabbè, ero quasi sicuro. Comunque volevo ringraziarti, sei stato molto gentile e paziente.

Michele.

8:02 PM  

Posta un commento

Iscriviti a Commenti sul post [Atom]

Link a questo post:

Crea un link

<< Home page